John works at a clothing store. He has a large pile of socks
that he must pair by color for sale. Given an array of integers representing
the color of each sock, determine how many pairs of socks with matching colors
there are.
For example, there are socks with colors . There
is one pair of color and one of color . There are three odd
socks left, one of each color. The number of pairs is .
Function Description
Complete the sockMerchant function
in the editor below. It must return an integer representing the number of
matching pairs of socks that are available.
sockMerchant has the following parameter(s):
·
n: the number of socks in the pile
·
ar: the colors of each sock
Input Format
The first line contains an integer , the number of socks
represented in .
The second line contains space-separated integers describing the colors of the socks in the pile.
The second line contains space-separated integers describing the colors of the socks in the pile.
Constraints
·
·
where
Output Format
Return the total number of matching pairs of
socks that John can sell.
Sample Input
9
10 20 20 10 10 30 50 10 20
Sample Output
3
Explanation
No of Unique pair in an Array using C# |
John can match three
pairs of socks.
This Problem is taken from Hacker rank
Solution
Step 1: we modify the Main method, you can make your own array size of 9, 10 ,11 it's upto you.
Step2: On sockMerchant Function we have create a array list , because its easy to add or remove the element form array list
static int sockMerchant(int n, int[] ar)
{
int count = 0;
ArrayList myList = new ArrayList();
foreach (var item in ar)
{
myList.Add(item);
}
for (int k = 0; k < myList.Count-1; k++)
{
for (int p = k + 1; p < myList.Count; p++)
{
if (Object.Equals(myList[k], myList[p]))
{
// myList.RemoveAt(k);
myList.RemoveAt(p);
count = count + 1;
break;
}
}
}
return count;
}
static void Main(string[] args)
{
Console.WriteLine("Enter the No of Stock Available");
int n = Convert.ToInt32(Console.ReadLine());
int[] ar = new int[n];
for (int i = 0; i <= n - 1; i++)
{
ar[i]= Convert.ToInt32(Console.ReadLine());
}
int result = sockMerchant(n, ar);
Console.WriteLine("result= "+result);
Console.ReadLine();
}
}
No of pair in an array using C# |
No comments:
Post a Comment